PowerTrain Pro: Automatic Transmission

Sponsored By: 

ATSG

Search Autoparts/Motorage/Powertrain-pro-automatic-transmission/

A Dodge harness problem

Wednesday, July 1, 2015 - 07:00
Print Article

A 2003 Dodge Ram 1500 Quad Cab 4x2 with a 5.7L engine and a 545RFE transmission comes into the shop in failsafe.

Motor Age Magazine Want more ? Enjoy a free subscription to Motor Age magazine to get the latest news in service repair. Click here to start you subscription today.

 Get more in-depth transmission knowledge with ATSG Manuals at 30% less!

ENTER CODE : ART30 AT CHECKOUT

Figure 1
Figure 2
Figure 3

Codes P1794 for a Speed Sensor Ground Error and P0871 for an OD Pressure Switch Rationality Sense Circuit were pulled. These two unrelated codes may suggest a wiring problem. With both the input and output speed sensors sharing the same TCM ground (T13) with the Transmission Range Sensor (TRS), P1794 was the first code to be approached. If the entire ground circuit was compromised a TRS code should also have been present and it was not. This would suggest that the ground problem would be located before the TRS splice down near the transmission.

With that in mind, a simple test would be to locate and ground the ground wire going to both the input and output speed sensors. This was a dark blue wire with a black tracer. When it was grounded P1794 was eliminated. This confirmed that a wiring issue was indeed present and may be the cause of P0871 as well. A scan tool also confirmed incorrect OD pressure switch signals were being seen by the TCM confirming wiring issues to be present. Tracking down the compromised location in the wiring harness has now become the daunting challenge.

After a variety of checks and inspections with no success, it was suggested to follow the harness up from the transmission to the rear of the engine. At times harnesses can be pinched between the transmission and a body seam. Or it can be mispositioned and get melted on the exhaust. In making this type of inspection the problem was located. Between the brake booster and plastic engine cover, the wiring harness rubbed through the edge of the plastic cover as seen in figures 1, 2 and 3. 

The question came up as to why the TRS did not code. The only thinking we had was that while driving the loss of vehicle speed occurred first once the wire was cut. Interestingly when the codes were erased the unit stayed in failsafe but the TCM was not giving up any codes. When all the wires were repaired every issue was eliminated.  We thank Donald from Covington Automotive for sharing this experience with us. 

Article Categorization
Article Details
Sponsored By: 

ATSG

< Previous
Next >
blog comments powered by Disqus